Back to overview
Resolved
PayFast payments degraded
Jul 23, 2026 at 1:45am UTC
Affected services
Payfast
Resolved
Jul 23, 2026 at 2:05am UTC
PayFast payment processing is operating normally.
More info available at https://status.payfast.io.
Affected services
Created
Jul 23, 2026 at 1:45am UTC
PayFast issues affecting: Payfast Aggregation: Cards, Payfast Gateway: Cards.
More info available at https://status.payfast.io.
Affected services