Back to overview
Resolved
PayFast payments degraded
Jul 20, 2026 at 10:20pm UTC
Affected services
Payfast
Resolved
Jul 21, 2026 at 11:06am UTC
PayFast payment processing is operating normally.
More info available at https://status.payfast.io.
Affected services
Created
Jul 20, 2026 at 10:20pm UTC
PayFast issues affecting: Payfast Aggregation: Instant EFT, Payfast Gateway: SiD.
More info available at https://status.payfast.io.
Affected services