Back to overview
Resolved
PayFast payments unavailable
Aug 13, 2026 at 11:15am UTC
Affected services
Payfast
Resolved
Aug 13, 2026 at 4:20pm UTC
PayFast payment processing is operating normally.
More info available at https://status.payfast.io.
Affected services
Created
Aug 13, 2026 at 11:15am UTC
PayFast issues affecting: Payfast Gateway: Alternative Payment Methods.
More info available at https://status.payfast.io.
Affected services